Das Plugin Simple Tags funktioniert unter WordPress 2.9 nicht, weil der Autor in der Zeile 35 von simple-tags.php die Versionsabfrage hardgecoded:

if ( strpos($wp_version, ‚2.7‘) !== false || strpos($wp_version, ‚2.8‘) !== false ) {

Wenn man den Code-Abschnitt mit folgendem ersetzt:

if ( strpos($wp_version, ‚2.7‘) !== false || strpos($wp_version, ‚2.8‘) !== false || strpos($wp_version, ‚2.9‘) !== false ) {

dann funktioniert das WordPress Plugin einwandfrei. Siehe dazu auch hier.

Was denkst du?