Fixing Revive (OpenX) Permission Error Warning

Nach einem Update von Revive (ehemals OpenX) bekomme ich nach der Anmeldung im WebGUI folgende Fehlermeldung angezeigt:

Error: File permission errors detected. These may impact the accurate delivery of your ads, See the debug.log file for the list of unwritable files

Leider ist diese Meldung absolut nichtsaussagend und helft einen nicht wirklich beim weiter um […]

weiterlesen ›

rndc: connect failed: 127.0.0.1#953: connection refused

Der Bind9-Dienst meldet bei einem Neustart das er den rdnc (BIND 9 name server control utility) nicht erreichen kann.

root@tux:~# service bind restart
Stopping domain name service…: bind9rndc: connect failed: 127.0.0.1#953: connection refused
waiting for pid 10879 to die.
Starting domain name service…: bind9.

Mit den folgenden zwei Befehlen kann man das […]

weiterlesen ›

Kein Syslog mehr nach Update von Debian Squeeze auf Wheezy

Beim Update von Debian Squeeze auf Wheezy wurde sysklogd Paket (bis auf die init-Skripte) deinstalliert.  Dies ist natürlich besonders ärgerlich, wenn auf dem System kein spezieller Daemonprozess mehr läuft, der das Systemlogbuch (syslog) schreibt.

Dieser Daemon empfängt nämlich Meldungen von anderen Prozessen und reagiert auf diese in unterschiedlicher Art und Weise. Das grundlegende Prinzip ist […]

weiterlesen ›

MRTG erzeugt SNMP_Session Fehlermeldungen unter Debian Wheezy

Heute habe ich einen alten “Testserver” von Debian Squeeze auf Wheezy aktualisiert. Seit dem Update sendet mir MRTG mehrmals stündlich eine E-Mail mit folgender Fehlermeldung:

Subroutine SNMP_Session::pack_sockaddr_in6 redefined at /usr/share/perl/5.14/Exporter.pm line 67.

Die Ursache für diesen Fehler liegt in Datei /usr/share/perl5/SNMP_Session.pm. Lösen kann man das Problem indem diese Datei an zwei Stellen wie folgt abändert:

[…]

weiterlesen ›

PHP5-Suhosin nach Dist-Upgrade von Debian Squeeze auf Wheezy

Heute habe ich einen alten „Testserver“ von Debian Squeeze auf Wheezy aktualisiert. Urspünglich war das Paket php5-suhosin installiert. Dieses Pakete ist aber in Wheezy nicht enthalten, weil es Kompatibilitätsprobleme gab. Aus diesem Grund gibt es nach dem Update auf Wheezy folgende Fehlermeldung:

PHP Warning:  PHP Startup: Unable to load dynamic library ‚/usr/lib/php5/20100525/suhosin.so‘ – /usr/lib/php5/20100525/suhosin.so: cannot […]

weiterlesen ›